iMac Vertical Lines Repair Forums All Forums Repairs and Issues After GPU repair issues (R8911 removal)

This topic contains 55 replies, has 15 voices, and was last updated by Adam - RealMacMods Adam – RealMacMods 8 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 56 total)
  • Author
    Posts
  • #3723

    See guide for updated info regarding High Sierra. Small additional hardware modification is required.

    ::date has been modified, so this reply appears first in topic. In hopes of people not needing to browse 4 pages of dead ends 😉 ::

    #1311

    OZ1BV
    Participant

    Hi
    Just did the R8911 removal (https://realmacmods.com/macbook-2011-radeon-gpu-disable/) on a MBP 15″ and 17″, both from 2011.
    I have installed High Sierra (10.13.1) on both of them and F1/F2 (brightness control) plus sleep mode is not working. The brightness slider is also gone in System Prefs -> Display.
    The strange thing is that if install El Capitan F1/F2 plus sleep mode is working.
    I have made an upgrade to High Sierra and also made a clean install. In both cases the above issue appeared.
    My guess is that the detection of hardware differs in High Sierra, compared to El Capitan. My hope is to find a way to install the possible missing KEXT. Any ideas are welcome 🙂

    Brian

    #1312

    This may be a stupid question, but have disabled the ambient light sensor in the system preferences?

    Also what happens when you hit F1 F2? Literally nothing or do you get screen animations?

    #1313

    OZ1BV
    Participant

    No questions are stupid 🙂

    Nothing happens at all when pressing F1/F2. In Display Settings the option “Automatic adjust brightness” has gone, and as written above, the Brightness adjustment as well.
    One of the machines is now reinstalled with El Capitan. I hope to figure out what differs compared to High Sierra.

    Brian

    #1314

    OZ1BV
    Participant

    The behaviour is very similar to what happens when all AMD KEXT’s are removed. My experiments ended up with only removing some AMD KEXT’s (https://forums.macrumors.com/threads/force-2011-macbook-pro-8-2-with-failed-amd-gpu-to-always-use-intel-integrated-gpu-efi-variable-fix.2037591/page-41 – starting at #1013). This tells me that some display functions are maintained in the AMD KEXT’s no matter which graphic card is active. Perhaps El Capitan is depending more on model information rather than detecting everything, and this has changed in High Sierra.

    Brian

    #1315

    can you upload a screen shot of your display preferences window? Also the graphics/display in “about this mac” system report. Maybe a quicktime screen recording of hitting function buttons? Screen brightness, volume, keyboard brightness, etc

    Also, have you done a full safe boot? The safe boot definitely clears out some errant AMD caches and whatnot.

    It seems odd that it would be kext related, when really how it works is just simple DDC messages to the backlight controller. So it should be related to the function key kexts, rather than the GPU kexts. I don’t doubt that Apple over complicated something, but it seems entirely unnecessary.

    Have you messed with KEXTS at this point on this MBP? I ask because all the ones I’ve done with the r8911 method, i did nothing at all with KEXTS.
    EFI MOD
    Safe Boot
    Shutdown
    r8911 removal

    Nothing else at all

    I don’t have one here to test functionality at the moment, but i would be so surprised if i sent them out with brightness and sleep non functional and no one complained.

    #1316

    OZ1BV
    Participant

    Just made an experiment: I upgraded to MacOS Sierra (Not High Sierra) on my 15″ MacBook. Sierra is working perfectly. F1/F2 and sleep mode is 100% ok. I will try a clean Sierra install and I will upgrade the Sierra to High Sierra and see what happens 🙂

    Brian

    #1317

    OZ1BV
    Participant

    I just got my hand on a 3. MBP 15″ with the famous GPU issue, a late 2011 version, and I did some experiments. The first thing I did was mounting a brand new SSD and then:

    1. Clean install of El Capitan. Everything works perfectly
    2. Clean install of Sierra. Everything works perfectly
    3. Clean install of High Sierra, F1/F2 does not work and sleep mode as well

    In all 3 cases I have been using the latest release of the OS.
    Safe boot did not change anything, but since it’s a clean install every time it makes sense.

    I repeated this on my other 15″ MBP (early 2011) 17″ MBP and the result was exactly the same.
    I have not been doing anything regarding KEXT’s ect.

    Before the R8911 removal I found out that removing all AMD*.* KEXT’s and files was making the OS, no matter which version, act in the same way as High Sierra does with the R8911 removed.
    With the R8911 in place i have removed the KEXT’s AMDRadeonX*.* and F1/F2 plus sleep mode works. This is why i think it is related to the KEXT’s in one way or another. I agree that it seems strange that the existence of some AMD related KEXT’s should have any influence on the issue. My experiment was just a long shot, but it worked 🙂

    The big question is now: What’s the difference between Sierra and High Sierra?

    I have attached 3 screen shots from the High Sierra installation and one from Sierra. 2 more will follow in next post

    Brian

    #1322

    OZ1BV
    Participant

    To screen shots from Sierra installation.

    #1325

    great work with the experimentation. Very thorough. I suppose the only glaring difference is the pixel depth changing, and the automatically adjust brightness changing. I wonder if High Sierra is not reading the EDID from the screen. I need to look into it more and see why this may be, and how to determine for sure.

    There are many complaints in other forums about brightness and sleep not working on other models (completely unmodified), so they changed something for sure.

    Just to be clear, your system profiler no longer shows the AMD GPU at all correct?

    Have you tried bridging r8911 back over and reseting NVRAM to clear the EFI work? I am just curious if functionality is restored, or if we are chasing our tails on an unrelated bug.

    #1326

    when you can, run these and post the output. i would like to decode the EDID and see if it is correct. If you could swap sierra and high sierra to gather results it would be even better.

    ioreg -l -x -w0 | grep DisplayProductID

    ioreg -l -x -w0 | grep DisplayVendorID

    ioreg -l -x -w0 | grep IODisplayPrefsKey

    ioreg -lw0 | grep IODisplayEDID

    #1327

    OZ1BV
    Participant

    It might be an issue that the EDID is not read. But the strange part is, if only the KEXT’s I mentioned earlier are removed and the R8911 is mounted, the F1/F2 and sleep mode is working in High Sierra.
    I will, when finished work, continue with ioreg.

    #1328

    OZ1BV
    Participant

    I have installed Sierra and High Sierra on the same machine and the result is in the ZIP file. There is no difference. So, it have to be something else.
    On the other MacBook I have followed the procedure carefully (Before and after removing R8911) and it acts in the same way.

    • This reply was modified 1 year, 2 months ago by  OZ1BV.
    Attachments:
    1. ioreg_Results.zip
    #1331

    Well at least it is consistent.

    I will decode this EDID and see what it is actually saying.

    #1332

    EDID looks to be valid and consistent with the LCD data sheet.

    how about

    kextstat | grep com.apple | grep light

    as well as

    nvram -xp

Viewing 15 posts - 1 through 15 (of 56 total)

The forum ‘Repairs and Issues’ is closed to new topics and replies.