iMac Vertical Lines Repair Forums All Forums Repairs and Issues After GPU repair issues (R8911 removal)

Viewing 15 posts - 31 through 45 (of 56 total)
  • Author
    Posts
  • #1636
    Avatarsedwo
    Participant

    So a short while ago I did the kext hack to get my 15″ 2011 MBP running and although “it worked”, it was flaky and sometimes after reboots it wouldn’t come back until I did a hard power down. So tonight I removed the resister and … now I have no screen at all. It’s black. The machine tries to boot but the video is completely dead.

    But, when I put my tiny screw driver across the SMT resistor leads that was removed and short the connection, then at reboot the screen comes back. Until I remove the short and it goes black again.

    Now what are my options?

    fyi: running high sierra.

    • This reply was modified 1 year, 10 months ago by Avatarsedwo.
    #1638

    Please review the procedure again. The kernel extension method is very different and not compatible with removal of r8911.

    You have merely killed the power (via r8911) to your GPU without providing the EFI instruction to route primary video to the Intel GPU.

    Advice is to bridge the R8911 pads and run the automated utility. After safe boot remove the bridge and you will be working only off the Intel GPU.

    – Adam

    #1660
    slickslick
    Participant

    After the patch, safe boot procedure shutdown, and removing the resistor the Mac works with the Intel graphics only but once it sleeps and then woken up the keyboard backlight turns on but no display on screen.

    In other words, macOS 10.13.2 will not come out of sleep… fully. no display but keyboard backlight and error sounds when you hit keys

    Any progress with this?

    #1675
    Avatarleelance
    Participant

    Just a +1 on the lack of brightness control on HighSierra.

    #1676
    Avatarleelance
    Participant

    Oh man. and another +1 on what @slick said about it not coming out of sleep. Whether you close the lid or it goes to sleep after screensaver, comes up to a black screen. You can adjust the keyboard backlight or change the caps lock so its not locked up… just no display. Hold power and reboot and it comes back from boot just fine.

    #1679
    Avatarleelance
    Participant

    Some more data for you @admin – i used TM to downgrade back to Yosemite, and everything works fine. Can adjust brightness, comes out of sleep just fine, etc. Happy to help test if you need any data, etc. from my end. Definitely know that my posts are intended to help and are in no way complaints. You saved my ass with your R8911 solution!

    #1680

    I appreciate the offer to help. If i need any testing i will send it your way. Still trying to determine what exactly is going on here.

    #1691
    Avatarmadman22fg
    Participant

    Hi there guys. I’m not sure if I should open another thread. First of all i would like to ask Adam to erase this post (https://realmacmods.com/forums/topic/problem-booting-with-arch-linux/). I solved the problem booting from cd instead usb and worked out perfectly. Sorry about that.
    Well, everything went ok with the gpu repair (radeon bypass and R8911 removal) but I’m having another problem…

    This is the thing. This motherboard had a reflow on the radeon about 2 years ago. I modified the back cover drilling some holes to let some air in, and it worked good ’til last november. I have a recording studio and as I was mixing, it just crashed. I turned it off. Turned it on again and had just a white screen. So that’s the last thing I did with that MBP. I have another and started working with that one. So a couple of days ago I started searching if a gpu bypass was possible and here I am. Well the thing is that the mb only starts with a smc bypass (connecting the magsafe while holding the power button for 10 seconds. I didn’t had to do that before, even after the gpu crashed. I thought it was because of the battery being fully discharged (for being almost 3 months in the bag). Tried smc reset. Tried nvpram reset (before doing the gpu work – I don’t wanna do it now as advertised on the tutorial). Tried unplugging the battery for 24 hours, tried charging for the same time and nothing. In normal conditions fans just spin and the machine turns off. With smc bypass it turns on ok but the system only boot’s ok in safe boot mode. I think I’m having some other electronic problem, but I really don’t know where to find. Oh, battery doesn’t charge at all (it was working ok before) and it’s not recognized on safe boot mode. Magsafe light is always green.

    The GPU repair worked flawlessly. The radeon gpu is not recognized anymore.

    Sorry for being too long on the story, I think every detail can give you guys a clue of what’s happening.

    #1692

    How about if you unplug the battery entirely and boot just from the magsafe? Batteries on the 2011 are notorious for swelling an causing a myriad of issues.

    #1712
    Avatarmadman22fg
    Participant

    Hi Adam, thanks for your reply! I tried that already. Nothing happens when I press the power button with the battery unpluged. I checked the chargers voltage on the board and it´s ok, I have the 16.5v on both pins (2 and 4). It start’s ok bypassing smc.
    If I unplug the battery, plug in the magsafe and then plug the battery again the fans automatically spin for 1 sec and then turn off. The “Restart automatically after a power failure” option on the Energy saver is unchecked. I found this doing some research (https://www.youtube.com/watch?v=7VltAzdVwqc), maybe that’s the problem? It seems strange to me since that didn’t happend when the gpu crashed.

    #1736
    AvatarWil Nelson
    Participant

    I am not sure how the following may relate to issues others are having but this is what I experienced with mod’s to 2011 17″ MacBook Pro

    After making terminal commands as instructed removed resistor and set EFI password today. Managed to also remove little resistor next to R8911 could not get it back in place so booted up computer. Had a rather small pointed tip but feel it was still to large for such a small item.

    Tried for about 45 minutes to get that little sucker soldered back in but no luck. May try another time using a Exacto type solder blade with very fine pointed tip due to ability to put heat exactly where needed.

    Checked all functions, USB, FireWire,CD drive etc an observed that I lost the ability to wake screen from sleep, computer wakes but screen stays black and have to restart. Computer is usually on or off so not much of a problem and set a long time to sleep just in case. Also, lost ability to dim/brighten screen using designated two “fn” keys. So, found Brighter-Screen Lite in App Store and fixed that problem with a Menu bar slider and setting Command left/right arrows for control of display brightness.

    Have not found a similar utility that will override display/computer sleep functions.

    The 17″ MacBook is now much more useable and of course considering I thought is was dead a few days ago this is a big improvement.

    #1737

    Hey Wil,

    It’s likely not related to the sleep issues but if you want to take a nice close up and clear picture of the PCB where you removed the additional SMD device and email it or post here i can consult the schematic and tell you what you removed.

    In all likelihood it was a bypass cap for the AMD and not needed, but I’m happy to look it up for you.

    – Adam

    #1738
    AvatarWil Nelson
    Participant

    Picture on the way. As I said in other e-mail the 2nd resistor right next to and parallel to R8911 might be the other leg of the power supply to the AMD chip.

    Wil

    #1739
    AvatarWil Nelson
    Participant

    Retrograded to Sierra 10.12 and all is fine. Sleep works, as AMD GPU is “not recognized’ no need to run Adams mod again.

    #1740
    AvatarAnonymous
    Inactive

    Hello.

Viewing 15 posts - 31 through 45 (of 56 total)
  • The forum ‘Repairs and Issues’ is closed to new topics and replies.